summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Asselstine <mark.asselstine@windriver.com>2017-02-08 12:53:28 -0500
committerBruce Ashfield <bruce.ashfield@windriver.com>2017-02-09 09:14:27 -0500
commitb2c365c37108c1ede6adbba45c158b7c68eed98e (patch)
treeb4684c59b8b05a7b895405e94c696d84e73aca80
parent2ef58c264b21d36255c2754abef43e0bee764ae8 (diff)
downloadmeta-virtualization-b2c365c37108c1ede6adbba45c158b7c68eed98e.tar.gz
docker: fixup failing build
Docker is failing to build because it is attempting to download missing go dependencies. Add new recipes for missing dependencies and update existing recipes to ensure the version defined in docker's vendor.conf is available. Note that this fixes the build only. At this time many docker functions are working, such as 'docker image', 'docker pull' and more, but 'docker run' is currently failing. Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--recipes-containers/docker/docker_git.bb6
-rw-r--r--recipes-devtools/go/compose-file_git.bb41
-rw-r--r--recipes-devtools/go/go-capability_git.bb3
-rw-r--r--recipes-devtools/go/go-connections_git.bb39
-rw-r--r--recipes-devtools/go/go-dbus_git.bb6
-rw-r--r--recipes-devtools/go/go-distribution_git.bb (renamed from recipes-devtools/go/go-distribution-digest_git.bb)15
-rw-r--r--recipes-devtools/go/go-fsnotify_git.bb4
-rw-r--r--recipes-devtools/go/go-libtrust_git.bb3
-rw-r--r--recipes-devtools/go/go-logrus_git.bb4
-rw-r--r--recipes-devtools/go/go-patricia_git.bb4
-rw-r--r--recipes-devtools/go/go-systemd_git.bb8
-rw-r--r--recipes-devtools/go/grpc-go_git.bb41
-rw-r--r--recipes-devtools/go/notary_git.bb39
13 files changed, 195 insertions, 18 deletions
diff --git a/recipes-containers/docker/docker_git.bb b/recipes-containers/docker/docker_git.bb
index 75da1861..ba9e0612 100644
--- a/recipes-containers/docker/docker_git.bb
+++ b/recipes-containers/docker/docker_git.bb
@@ -51,7 +51,11 @@ DEPENDS = " \
51 go-systemd \ 51 go-systemd \
52 btrfs-tools \ 52 btrfs-tools \
53 sqlite3 \ 53 sqlite3 \
54 go-distribution-digest \ 54 go-distribution \
55 compose-file \
56 go-connections \
57 notary \
58 grpc-go \
55 " 59 "
56 60
57PACKAGES =+ "${PN}-contrib" 61PACKAGES =+ "${PN}-contrib"
diff --git a/recipes-devtools/go/compose-file_git.bb b/recipes-devtools/go/compose-file_git.bb
new file mode 100644
index 00000000..bcf8c3d2
--- /dev/null
+++ b/recipes-devtools/go/compose-file_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "Parser for the Compose file format (version 3)"
2HOMEPAGE = "https://github.com/aanand/compose-file"
3SECTION = "devel/go"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=9cd86830b557232ce55e2a6b47387471"
6
7SRCNAME = "compose-file"
8
9PKG_NAME = "github.com/aanand/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
11
12SRCREV = "a3e58764f50597b6217fec07e9bff7225c4a1719"
13PV = "3.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17# NO-OP the do compile rule because this recipe is source only.
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30}
31
32SYSROOT_PREPROCESS_FUNCS += "go_compose_file_sysroot_preprocess"
33
34go_compose_file_sysroot_preprocess () {
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
36 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
37}
38
39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
40
41CLEANBROKEN = "1" \ No newline at end of file
diff --git a/recipes-devtools/go/go-capability_git.bb b/recipes-devtools/go/go-capability_git.bb
index 4f8f4316..8524af62 100644
--- a/recipes-devtools/go/go-capability_git.bb
+++ b/recipes-devtools/go/go-capability_git.bb
@@ -9,7 +9,8 @@ SRCNAME = "gocapability"
9PKG_NAME = "github.com/syndtr/${SRCNAME}" 9PKG_NAME = "github.com/syndtr/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "8e4cdcb3c22b40d5e330ade0b68cb2e2a3cf6f98" 12SRCREV = "2c00daeb6c3b45114c80ac44119e7b8801fdd852"
13PV = "0.0+git${SRCPV}"
13 14
14S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
15 16
diff --git a/recipes-devtools/go/go-connections_git.bb b/recipes-devtools/go/go-connections_git.bb
new file mode 100644
index 00000000..5d071b0a
--- /dev/null
+++ b/recipes-devtools/go/go-connections_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Utility package to work with network connections"
2HOMEPAGE = "https://github.com/docker/connections"
3SECTION = "devel/go"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=04424bc6f5a5be60691b9824d65c2ad8"
6
7SRCNAME = "go-connections"
8
9PKG_NAME = "github.com/docker/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
11
12SRCREV = "4ccf312bf1d35e5dbda654e57a9be4c3f3cd0366"
13PV = "0.2.1+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17# NO-OP the do compile rule because this recipe is source only.
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30}
31
32SYSROOT_PREPROCESS_FUNCS += "go_connections_sysroot_preprocess"
33
34go_connections_sysroot_preprocess () {
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
36 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
37}
38
39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"
diff --git a/recipes-devtools/go/go-dbus_git.bb b/recipes-devtools/go/go-dbus_git.bb
index 092bd502..9b206a1e 100644
--- a/recipes-devtools/go/go-dbus_git.bb
+++ b/recipes-devtools/go/go-dbus_git.bb
@@ -2,15 +2,15 @@ DESCRIPTION = "Native Go bindings for D-Bus"
2HOMEPAGE = "https://github.com/godbus/dbus" 2HOMEPAGE = "https://github.com/godbus/dbus"
3SECTION = "devel/go" 3SECTION = "devel/go"
4LICENSE = "BSD-2-Clause" 4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b5ac622301483800715d770434e27e5b" 5LIC_FILES_CHKSUM = "file://LICENSE;md5=09042bd5c6c96a2b9e45ddf1bc517eed"
6 6
7SRCNAME = "dbus" 7SRCNAME = "dbus"
8 8
9PKG_NAME = "github.com/godbus/${SRCNAME}" 9PKG_NAME = "github.com/godbus/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "88765d85c0fdadcd98a54e30694fa4e4f5b51133" 12SRCREV = "5f6efc7ef2759c81b7ba876593971bfce311eab3"
13PV = "2+git${SRCREV}" 13PV = "4.0.0+git${SRCREV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-devtools/go/go-distribution-digest_git.bb b/recipes-devtools/go/go-distribution_git.bb
index 2a803da5..9e3f2093 100644
--- a/recipes-devtools/go/go-distribution-digest_git.bb
+++ b/recipes-devtools/go/go-distribution_git.bb
@@ -2,14 +2,15 @@ DESCRIPTION = "The Docker toolset to pack, ship, store, and deliver content"
2HOMEPAGE = "https://github.com/docker/distribution" 2HOMEPAGE = "https://github.com/docker/distribution"
3SECTION = "devel/go" 3SECTION = "devel/go"
4LICENSE = "Apache-2.0" 4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=d2794c0df5b907fdace235a619d80314" 5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=d2794c0df5b907fdace235a619d80314"
6 6
7SRCNAME = "distribution" 7SRCNAME = "distribution"
8 8
9PKG_NAME = "github.com/docker/${SRCNAME}" 9PKG_NAME = "github.com/docker/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git;branch=docker/1.13;destsuffix=git/src/${PKG_NAME}"
11 11
12SRCREV = "d957768537c5af40e4f4cd96871f7b2bde9e2923" 12SRCREV = "28602af35aceda2f8d571bad7ca37a54cf0250bc"
13PV = "2.6.0+git${SRCPV}"
13 14
14S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
15 16
@@ -19,7 +20,13 @@ do_compile() {
19 20
20do_install() { 21do_install() {
21 install -d ${D}${prefix}/local/go/src/${PKG_NAME} 22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
22 cp -r ${S}/LICENSE ${S}/digest ${D}${prefix}/local/go/src/${PKG_NAME}/ 23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
23} 30}
24 31
25SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess" 32SYSROOT_PREPROCESS_FUNCS += "go_distribution_digeset_sysroot_preprocess"
diff --git a/recipes-devtools/go/go-fsnotify_git.bb b/recipes-devtools/go/go-fsnotify_git.bb
index e18f574a..e5bcf145 100644
--- a/recipes-devtools/go/go-fsnotify_git.bb
+++ b/recipes-devtools/go/go-fsnotify_git.bb
@@ -9,8 +9,8 @@ SRCNAME = "fsnotify"
9PKG_NAME = "github.com/go-fsnotify/${SRCNAME}" 9PKG_NAME = "github.com/go-fsnotify/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "ca50e738d35a862c379baf8fffbc3bfd080b3cff" 12SRCREV = "836bfd95fecc0f1511dd66bdbf2b5b61ab8b00b6"
13PV = "1.0.4+git${SRCREV}" 13PV = "1.2.11+git${SRCREV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-devtools/go/go-libtrust_git.bb b/recipes-devtools/go/go-libtrust_git.bb
index f2acfb43..55659464 100644
--- a/recipes-devtools/go/go-libtrust_git.bb
+++ b/recipes-devtools/go/go-libtrust_git.bb
@@ -9,7 +9,8 @@ SRCNAME = "libtrust"
9PKG_NAME = "github.com/docker/${SRCNAME}" 9PKG_NAME = "github.com/docker/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "230dfd18c2326f1e9d08238710e67a1040187d07" 12SRCREV = "9cbd2a1374f46905c68a4eb3694a130610adc62a"
13PV = "0.0+git${SRCPV}"
13 14
14S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
15 16
diff --git a/recipes-devtools/go/go-logrus_git.bb b/recipes-devtools/go/go-logrus_git.bb
index 082c1a68..5c0c3595 100644
--- a/recipes-devtools/go/go-logrus_git.bb
+++ b/recipes-devtools/go/go-logrus_git.bb
@@ -9,8 +9,8 @@ SRCNAME = "logrus"
9PKG_NAME = "github.com/Sirupsen/${SRCNAME}" 9PKG_NAME = "github.com/Sirupsen/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "3fc34d061b9c78a70db853c7cb6b0576b6d4f32d" 12SRCREV = "d26492970760ca5d33129d2d799e34be5c4782eb"
13PV = "0.7.1+git${SRCREV}" 13PV = "0.11.0+git${SRCREV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-devtools/go/go-patricia_git.bb b/recipes-devtools/go/go-patricia_git.bb
index 18c188d3..8c1e10d9 100644
--- a/recipes-devtools/go/go-patricia_git.bb
+++ b/recipes-devtools/go/go-patricia_git.bb
@@ -9,8 +9,8 @@ SRCNAME = "go-patricia"
9PKG_NAME = "github.com/tchap/${SRCNAME}" 9PKG_NAME = "github.com/tchap/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "f64d0a63cd3363481c898faa9339de04d12213f9" 12SRCREV = "666120de432aea38ab06bd5c818f04f4129882c9"
13PV = "1.0.1+git${SRCPV}" 13PV = "2.2.6+git${SRCPV}"
14 14
15S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
16 16
diff --git a/recipes-devtools/go/go-systemd_git.bb b/recipes-devtools/go/go-systemd_git.bb
index 358e6bb4..5cbab92e 100644
--- a/recipes-devtools/go/go-systemd_git.bb
+++ b/recipes-devtools/go/go-systemd_git.bb
@@ -9,8 +9,12 @@ SRCNAME = "systemd"
9PKG_NAME = "github.com/coreos/go-${SRCNAME}" 9PKG_NAME = "github.com/coreos/go-${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git" 10SRC_URI = "git://${PKG_NAME}.git"
11 11
12SRCREV = "f743bc15d6bddd23662280b4ad20f7c874cdd5ad" 12SRCREV = "b4a58d95188dd092ae20072bac14cece0e67c388"
13PV = "2+git${SRCREV}" 13PV = "4+git${SRCREV}"
14
15DEPENDS += " \
16 bash \
17"
14 18
15S = "${WORKDIR}/git" 19S = "${WORKDIR}/git"
16 20
diff --git a/recipes-devtools/go/grpc-go_git.bb b/recipes-devtools/go/grpc-go_git.bb
new file mode 100644
index 00000000..48c42499
--- /dev/null
+++ b/recipes-devtools/go/grpc-go_git.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "The Go language implementation of gRPC. HTTP/2 based RPC"
2HOMEPAGE = "https://github.com/grpc/grpc-go"
3SECTION = "devel/go"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=a4bad33881612090c6035d8393175996"
6
7SRCNAME = "grpc-go"
8
9PKG_NAME = "google.golang.org/grpc"
10SRC_URI = "git://github.com/grpc/${SRCNAME}.git;destsuffix=git/src/${PKG_NAME}"
11
12SRCREV = "777daa17ff9b5daef1cfdf915088a2ada3332bf0"
13PV = "1.4.0+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17# NO-OP the do compile rule because this recipe is source only.
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30}
31
32SYSROOT_PREPROCESS_FUNCS += "go_grpc_sysroot_preprocess"
33
34go_grpc_sysroot_preprocess () {
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
36 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
37}
38
39FILES_${PN} += " \
40 ${prefix}/local/go/src/${PKG_NAME}/* \
41"
diff --git a/recipes-devtools/go/notary_git.bb b/recipes-devtools/go/notary_git.bb
new file mode 100644
index 00000000..d638dc1c
--- /dev/null
+++ b/recipes-devtools/go/notary_git.bb
@@ -0,0 +1,39 @@
1DESCRIPTION = "Notary is a Docker project that allows anyone to have trust over arbitrary collections of data"
2HOMEPAGE = "https://github.com/docker/notary"
3SECTION = "devel/go"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://src/${PKG_NAME}/LICENSE;md5=771ddb425ba03c8fab49e5bd9854a4a2"
6
7SRCNAME = "notary"
8
9PKG_NAME = "github.com/docker/${SRCNAME}"
10SRC_URI = "git://${PKG_NAME}.git;destsuffix=git/src/${PKG_NAME}"
11
12SRCREV = "c8aa8cf53cbcda2e92def0c9291e25d770493494"
13PV = "0.4.2+git${SRCPV}"
14
15S = "${WORKDIR}/git"
16
17# NO-OP the do compile rule because this recipe is source only.
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${prefix}/local/go/src/${PKG_NAME}
23 for j in $(cd ${S} && find src/${PKG_NAME} -name "*.go"); do
24 if [ ! -d ${D}${prefix}/local/go/$(dirname $j) ]; then
25 mkdir -p ${D}${prefix}/local/go/$(dirname $j)
26 fi
27 cp $j ${D}${prefix}/local/go/$j
28 done
29 cp -r ${S}/src/${PKG_NAME}/LICENSE ${D}${prefix}/local/go/src/${PKG_NAME}/
30}
31
32SYSROOT_PREPROCESS_FUNCS += "go_notary_sysroot_preprocess"
33
34go_notary_sysroot_preprocess () {
35 install -d ${SYSROOT_DESTDIR}${prefix}/local/go/src/${PKG_NAME}
36 cp -r ${D}${prefix}/local/go/src/${PKG_NAME} ${SYSROOT_DESTDIR}${prefix}/local/go/src/$(dirname ${PKG_NAME})
37}
38
39FILES_${PN} += "${prefix}/local/go/src/${PKG_NAME}/*"