diff options
author | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-06-27 13:19:54 -0400 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-06-27 13:19:54 -0400 |
commit | b44a92c0f3de17639fda9de10ac0b30f19e41862 (patch) | |
tree | 43cc5de883a25a4230da003b3c7d348a8b6e2076 | |
parent | c1b428f3d2fe4175b06acc9f466863b766d9c149 (diff) | |
download | meta-virtualization-b44a92c0f3de17639fda9de10ac0b30f19e41862.tar.gz |
devtools: remove protobuf*
The protobuf recipes are in meta-oe, and were only here to support
higher order virtualization tasks.
Dropping the recipes and we'll use the ones directly from meta-oe,
since the versions and compatibility should be fine.
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
6 files changed, 0 insertions, 234 deletions
diff --git a/recipes-devtools/protobuf/files/disable_tests.patch b/recipes-devtools/protobuf/files/disable_tests.patch deleted file mode 100644 index f5e71ca6..00000000 --- a/recipes-devtools/protobuf/files/disable_tests.patch +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | diff -Naur protobuf-c-0.15.old/src/Makefile.am protobuf-c-0.15/src/Makefile.am | ||
2 | --- protobuf-c-0.15.old/src/Makefile.am 2012-11-28 14:59:57.845251943 +0100 | ||
3 | +++ protobuf-c-0.15/src/Makefile.am 2012-11-28 15:00:23.549252632 +0100 | ||
4 | @@ -1,5 +1,5 @@ | ||
5 | if BUILD_PROTOC_C | ||
6 | -SUBDIRS = . test | ||
7 | + | ||
8 | bin_PROGRAMS = protoc-c | ||
9 | protoc_c_SOURCES = \ | ||
10 | google/protobuf/compiler/c/c_service.cc \ | ||
11 | @@ -23,7 +23,7 @@ | ||
12 | lib_LTLIBRARIES = libprotobuf-c.la | ||
13 | protobufcincludedir = $(includedir)/google/protobuf-c | ||
14 | |||
15 | -EXTRA_DIST = CMakeLists.txt test/CMakeLists.txt | ||
16 | +EXTRA_DIST = CMakeLists.txt | ||
17 | |||
18 | libprotobuf_c_la_SOURCES = \ | ||
19 | google/protobuf-c/protobuf-c-dispatch.c \ | ||
diff --git a/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch b/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch deleted file mode 100644 index 8b293428..00000000 --- a/recipes-devtools/protobuf/files/protobuf-allow-running-python-scripts-from-anywhere.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | From 46e331263eb92e47510e88478b255f226d30245c Mon Sep 17 00:00:00 2001 | ||
2 | From: Keith Holman <Keith.Holman@windriver.com> | ||
3 | Date: Mon, 18 Aug 2014 15:19:35 -0400 | ||
4 | Subject: [PATCH] protobuf: allow running python scripts from anywhere | ||
5 | |||
6 | The Makefile to generate the examples with Google Protocol Buffers | ||
7 | generates some scripts for python. However, these generated scripts | ||
8 | only work if they are ran in the same directory as the source files. | ||
9 | This fix generates scripts to execute from anywhere on the system. | ||
10 | |||
11 | Signed-off-by: Keith Holman <Keith.Holman@windriver.com> | ||
12 | --- | ||
13 | examples/Makefile | 6 ++++-- | ||
14 | 1 file changed, 4 insertions(+), 2 deletions(-) | ||
15 | |||
16 | diff --git a/examples/Makefile b/examples/Makefile | ||
17 | index 8dc9083..a993d63 100644 | ||
18 | --- a/examples/Makefile | ||
19 | +++ b/examples/Makefile | ||
20 | @@ -48,11 +48,13 @@ list_people_java: javac_middleman | ||
21 | add_person_python: add_person.py protoc_middleman | ||
22 | @echo "Writing shortcut script add_person_python..." | ||
23 | @echo '#! /bin/sh' > add_person_python | ||
24 | - @echo './add_person.py "$$@"' >> add_person_python | ||
25 | + @echo 'SCRIPT_DIR=$$(dirname $$0)' >> add_person_python | ||
26 | + @echo '$$SCRIPT_DIR/add_person.py "$$@"' >> add_person_python | ||
27 | @chmod +x add_person_python | ||
28 | |||
29 | list_people_python: list_people.py protoc_middleman | ||
30 | @echo "Writing shortcut script list_people_python..." | ||
31 | @echo '#! /bin/sh' > list_people_python | ||
32 | - @echo './list_people.py "$$@"' >> list_people_python | ||
33 | + @echo 'SCRIPT_DIR=$$(dirname $$0)' >> list_people_python | ||
34 | + @echo '$$SCRIPT_DIR/list_people.py "$$@"' >> list_people_python | ||
35 | @chmod +x list_people_python | ||
36 | -- | ||
37 | 1.9.3 | ||
38 | |||
diff --git a/recipes-devtools/protobuf/files/run-ptest b/recipes-devtools/protobuf/files/run-ptest deleted file mode 100755 index a5a7b0f9..00000000 --- a/recipes-devtools/protobuf/files/run-ptest +++ /dev/null | |||
@@ -1,32 +0,0 @@ | |||
1 | #!/bin/bash | ||
2 | DIR="$( cd "$( dirname "${BASH_SOURCE[0]}" )" && pwd )" | ||
3 | TEST_FILE="/tmp/test.data" | ||
4 | |||
5 | RETVAL=0 | ||
6 | # Test every writing test application | ||
7 | for write_exe_full_path in ${DIR}/add_person_*; do | ||
8 | if [ -x "${write_exe_full_path}" ]; then | ||
9 | write_exe=`basename ${write_exe_full_path}` | ||
10 | echo "Generating new test file using ${write_exe}..." | ||
11 | ${write_exe_full_path} "${TEST_FILE}" | ||
12 | RETVAL=$? | ||
13 | |||
14 | # Test every reading test application | ||
15 | for read_exe_full_path in ${DIR}/list_people_*; do | ||
16 | read_exe=`basename ${read_exe_full_path}` | ||
17 | echo "Test: Write with ${write_exe}; Read with ${read_exe}..." | ||
18 | if [ -x "${read_exe_full_path}" ]; then | ||
19 | ${read_exe_full_path} "${TEST_FILE}" | ||
20 | RETVAL=$? | ||
21 | fi | ||
22 | done | ||
23 | |||
24 | # Cleanup... | ||
25 | if [ -e "${TEST_FILE}" ]; then | ||
26 | rm "${TEST_FILE}" | ||
27 | fi | ||
28 | fi | ||
29 | done | ||
30 | |||
31 | exit $RETVAL | ||
32 | |||
diff --git a/recipes-devtools/protobuf/protobuf-c_1.2.1.bb b/recipes-devtools/protobuf/protobuf-c_1.2.1.bb deleted file mode 100644 index ff2499e5..00000000 --- a/recipes-devtools/protobuf/protobuf-c_1.2.1.bb +++ /dev/null | |||
@@ -1,28 +0,0 @@ | |||
1 | SUMMARY = "protobuf-c" | ||
2 | DESCRIPTION = "This package provides a code generator and runtime libraries to use Protocol Buffers from pure C" | ||
3 | HOMEPAGE = "http://code.google.com/p/protobuf-c/" | ||
4 | SECTION = "console/tools" | ||
5 | LICENSE = "Apache-2.0" | ||
6 | |||
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=235c3195a3968524dc1524b4ebea0c0e" | ||
8 | |||
9 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" | ||
10 | |||
11 | DEPENDS = "protobuf protobuf-c-native" | ||
12 | |||
13 | SRC_URI[md5sum] = "e544249c329391fff512c3874895cfbe" | ||
14 | SRC_URI[sha256sum] = "846eb4846f19598affdc349d817a8c4c0c68fd940303e6934725c889f16f00bd" | ||
15 | SRC_URI = "https://github.com/protobuf-c/protobuf-c/releases/download/v1.2.1/protobuf-c-1.2.1.tar.gz " | ||
16 | #SRC_URI_append_class-target ="file://0001-protobuf-c-Remove-the-rules-which-depend-on-the-nati.patch" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
19 | |||
20 | BBCLASSEXTEND = "native nativesdk" | ||
21 | |||
22 | do_configure_prepend_class-target() { | ||
23 | export PKG_CONFIG_PATH="${STAGING_LIBDIR_NATIVE}/pkgconfig:${PKG_CONFIG_PATH}" | ||
24 | } | ||
25 | |||
26 | do_install_append_class-native() { | ||
27 | install -m 755 ${B}/t/generated-code2/cxx-generate-packed-data ${D}/${bindir} | ||
28 | } | ||
diff --git a/recipes-devtools/protobuf/protobuf-native_3.1.0.bb b/recipes-devtools/protobuf/protobuf-native_3.1.0.bb deleted file mode 100644 index c32f6278..00000000 --- a/recipes-devtools/protobuf/protobuf-native_3.1.0.bb +++ /dev/null | |||
@@ -1,19 +0,0 @@ | |||
1 | SUMMARY = "protobuf" | ||
2 | DESCRIPTION = "Protocol Buffers are a way of encoding structured data in \ | ||
3 | an efficient yet extensible format. Google uses Protocol Buffers for \ | ||
4 | almost all of its internal RPC protocols and file formats." | ||
5 | HOMEPAGE = "http://code.google.com/p/protobuf/" | ||
6 | SECTION = "console/tools" | ||
7 | LICENSE = "BSD-3-Clause" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095" | ||
10 | |||
11 | SRC_URI[md5sum] = "14a532a7538551d5def317bfca41dace" | ||
12 | SRC_URI[sha256sum] = "0a0ae63cbffc274efb573bdde9a253e3f32e458c41261df51c5dbc5ad541e8f7" | ||
13 | SRC_URI = "https://github.com/google/protobuf/archive/v3.1.0.tar.gz;downloadfilename=protobuf-3.1.0.tar.gz \ | ||
14 | " | ||
15 | |||
16 | EXTRA_OECONF += " --with-protoc=echo" | ||
17 | |||
18 | inherit native autotools | ||
19 | |||
diff --git a/recipes-devtools/protobuf/protobuf_3.1.0.bb b/recipes-devtools/protobuf/protobuf_3.1.0.bb deleted file mode 100644 index b948e66a..00000000 --- a/recipes-devtools/protobuf/protobuf_3.1.0.bb +++ /dev/null | |||
@@ -1,98 +0,0 @@ | |||
1 | SUMMARY = "protobuf" | ||
2 | DESCRIPTION = "Protocol Buffers are a way of encoding structured data in \ | ||
3 | an efficient yet extensible format. Google uses Protocol Buffers for \ | ||
4 | almost all of its internal RPC protocols and file formats." | ||
5 | HOMEPAGE = "http://code.google.com/p/protobuf/" | ||
6 | SECTION = "console/tools" | ||
7 | LICENSE = "BSD-3-Clause" | ||
8 | |||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=35953c752efc9299b184f91bef540095" | ||
10 | |||
11 | PR = "r0" | ||
12 | EXCLUDE_FROM_WORLD = "1" | ||
13 | |||
14 | SRC_URI[md5sum] = "14a532a7538551d5def317bfca41dace" | ||
15 | SRC_URI[sha256sum] = "0a0ae63cbffc274efb573bdde9a253e3f32e458c41261df51c5dbc5ad541e8f7" | ||
16 | SRC_URI = "https://github.com/google/protobuf/archive/v3.1.0.tar.gz;downloadfilename=protobuf-3.1.0.tar.gz\ | ||
17 | file://protobuf-allow-running-python-scripts-from-anywhere.patch \ | ||
18 | file://run-ptest \ | ||
19 | " | ||
20 | |||
21 | COMPATIBLE_HOST = "(x86_64|arm|aarch64).*-linux" | ||
22 | |||
23 | EXTRA_OECONF += " --with-protoc=${STAGING_BINDIR_NATIVE}/protoc" | ||
24 | inherit autotools setuptools ptest | ||
25 | |||
26 | DEPENDS += "protobuf-native" | ||
27 | RDEPENDS_${PN}-ptest = "bash" | ||
28 | |||
29 | PYTHON_SRC_DIR="python" | ||
30 | TEST_SRC_DIR="examples" | ||
31 | LANG_SUPPORT="cpp python" | ||
32 | |||
33 | do_compile() { | ||
34 | # Compile protoc compiler | ||
35 | base_do_compile | ||
36 | } | ||
37 | |||
38 | do_compile_ptest() { | ||
39 | # Modify makefile to use the cross-compiler | ||
40 | sed -e "s|c++|${CXX} \$(LDFLAGS)|g" -i "${S}/${TEST_SRC_DIR}/Makefile" | ||
41 | |||
42 | mkdir -p "${B}/${TEST_SRC_DIR}" | ||
43 | |||
44 | # Add the location of the cross-compiled header and library files | ||
45 | # which haven't been installed yet. | ||
46 | cp "${B}/protobuf.pc" "${B}/${TEST_SRC_DIR}/protobuf.pc" | ||
47 | sed -e 's|libdir=|libdir=${PKG_CONFIG_SYSROOT_DIR}|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc" | ||
48 | sed -e 's|Cflags:|Cflags: -I${S}/src|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc" | ||
49 | sed -e 's|Libs:|Libs: -L${B}/src/.libs|' -i "${B}/${TEST_SRC_DIR}/protobuf.pc" | ||
50 | export PKG_CONFIG_PATH="${B}/${TEST_SRC_DIR}" | ||
51 | |||
52 | # Save the pkgcfg sysroot variable, and update it to nothing so | ||
53 | # that it doesn't append the sysroot to the beginning of paths. | ||
54 | # The header and library files aren't installed to the target | ||
55 | # system yet. So the absolute paths were specified above. | ||
56 | save_pkg_config_sysroot_dir=$PKG_CONFIG_SYSROOT_DIR | ||
57 | export PKG_CONFIG_SYSROOT_DIR= | ||
58 | |||
59 | # Compile the tests | ||
60 | for lang in ${LANG_SUPPORT}; do | ||
61 | oe_runmake -C "${S}/${TEST_SRC_DIR}" ${lang} | ||
62 | done | ||
63 | |||
64 | # Restore the pkgconfig sysroot variable | ||
65 | export PKG_CONFIG_SYSROOT_DIR=$save_pkg_config_sysroot_dir | ||
66 | } | ||
67 | |||
68 | do_install() { | ||
69 | local olddir=`pwd` | ||
70 | |||
71 | # Install protoc compiler | ||
72 | autotools_do_install | ||
73 | |||
74 | # Install header files | ||
75 | export PROTOC="${STAGING_BINDIR_NATIVE}/protoc" | ||
76 | cd "${S}/${PYTHON_SRC_DIR}" | ||
77 | distutils_do_install | ||
78 | |||
79 | cd "$olddir" | ||
80 | } | ||
81 | |||
82 | do_install_ptest() { | ||
83 | local olddir=`pwd` | ||
84 | |||
85 | cd "${S}/${TEST_SRC_DIR}" | ||
86 | install -d "${D}/${PTEST_PATH}" | ||
87 | for i in add_person* list_people*; do | ||
88 | if [ -x "$i" ]; then | ||
89 | install "$i" "${D}/${PTEST_PATH}" | ||
90 | fi | ||
91 | done | ||
92 | cp "${S}/${TEST_SRC_DIR}/addressbook_pb2.py" "${D}/${PTEST_PATH}" | ||
93 | |||
94 | cd "$olddir" | ||
95 | } | ||
96 | |||
97 | BBCLASSEXTEND = "nativesdk" | ||
98 | |||