summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-02-27 14:01:24 -0800
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-03-02 15:04:28 -0500
commitc925905e38acd6fed7ddf960abbc70634014efb5 (patch)
treea465c2acd4e3221cbc7c8010fa7568ed4d61f12d
parentf770151b3ff0938bea4972abdd1ee7f6cbc3a074 (diff)
downloadmeta-virtualization-c925905e38acd6fed7ddf960abbc70634014efb5.tar.gz
xen-image-minimal: enable runqemu for x86-64
Booting this Xen image with QEMU works when launching from the wic-generated pcbios disk image with the directdisk-xen.wks kickstart file, so add the variable settings to make doing it simple -- eg: runqemu xen-image-minimal nographic slirp Tested with MACHINEs: qemux86-64 and genericx86-64 Memory allocated to qemu is increased slightly over the default to allow for running Xen and the Linux dom0 and guest VMs. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r--recipes-extended/images/xen-image-minimal.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index dcdc864a..c965f221 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -72,3 +72,16 @@ build_syslinux_cfg () {
72 echo " APPEND /xen.gz ${SYSLINUX_XEN_ARGS} --- /vmlinuz ${SYSLINUX_KERNEL_ARGS} --- /initrd" >> ${SYSLINUX_CFG} 72 echo " APPEND /xen.gz ${SYSLINUX_XEN_ARGS} --- /vmlinuz ${SYSLINUX_KERNEL_ARGS} --- /initrd" >> ${SYSLINUX_CFG}
73} 73}
74 74
75# Enable runqemu. eg: runqemu xen-image-minimal nographic slirp
76WKS_FILE_x86-64 = "directdisk-xen.wks"
77QB_MEM = "-m 400"
78QB_DEFAULT_KERNEL = ""
79QB_DEFAULT_FSTYPE = "wic"
80QB_FSINFO = "wic:kernel-in-fs"
81# qemux86-64 machine does not include 'wic' in IMAGE_FSTYPES, which is needed
82# to boot this image, so add it here:
83IMAGE_FSTYPES_qemux86-64 += "wic"
84# Networking: the qemuboot.bbclass default virtio network device works ok
85# and so does the emulated e1000 -- choose according to the network device
86# drivers that are present in your dom0 Linux kernel. To switch to e1000:
87# QB_NETWORK_DEVICE = "-device e1000,netdev=net0,mac=@MAC@"