summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/images/xen-image-minimal.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-extended/images/xen-image-minimal.bb b/recipes-extended/images/xen-image-minimal.bb
index dcdc864a..c965f221 100644
--- a/recipes-extended/images/xen-image-minimal.bb
+++ b/recipes-extended/images/xen-image-minimal.bb
@@ -72,3 +72,16 @@ build_syslinux_cfg () {
72 echo " APPEND /xen.gz ${SYSLINUX_XEN_ARGS} --- /vmlinuz ${SYSLINUX_KERNEL_ARGS} --- /initrd" >> ${SYSLINUX_CFG} 72 echo " APPEND /xen.gz ${SYSLINUX_XEN_ARGS} --- /vmlinuz ${SYSLINUX_KERNEL_ARGS} --- /initrd" >> ${SYSLINUX_CFG}
73} 73}
74 74
75# Enable runqemu. eg: runqemu xen-image-minimal nographic slirp
76WKS_FILE_x86-64 = "directdisk-xen.wks"
77QB_MEM = "-m 400"
78QB_DEFAULT_KERNEL = ""
79QB_DEFAULT_FSTYPE = "wic"
80QB_FSINFO = "wic:kernel-in-fs"
81# qemux86-64 machine does not include 'wic' in IMAGE_FSTYPES, which is needed
82# to boot this image, so add it here:
83IMAGE_FSTYPES_qemux86-64 += "wic"
84# Networking: the qemuboot.bbclass default virtio network device works ok
85# and so does the emulated e1000 -- choose according to the network device
86# drivers that are present in your dom0 Linux kernel. To switch to e1000:
87# QB_NETWORK_DEVICE = "-device e1000,netdev=net0,mac=@MAC@"