diff options
author | Michal Orzel <michal.orzel@arm.com> | 2022-03-09 11:09:06 +0000 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2022-03-10 14:42:22 -0500 |
commit | ca4601a54a9cabe2c2bb8eb758bcad2d3ab98ddf (patch) | |
tree | 0b4e58cc34b238d76415c01024b91e9b2e77ee28 | |
parent | 2dc502a2690ed07b8e692b95d769803ec9f8eb21 (diff) | |
download | meta-virtualization-ca4601a54a9cabe2c2bb8eb758bcad2d3ab98ddf.tar.gz |
xen: Override CC and CPP in make command line
After 4.16 release, Xen build system has been changed significantly.
When building latest status of Xen it was observed that commit
317c98cb91 broke the hypervisor build on arm32 due to the change in
handling Rules.mk that xen.inc modifies to override CC and CPP.
In order to fix the issue this patch moves overriding CC and CPP from
Rules.mk to make command line by adding them to EXTRA_OEMAKE:arm.
Take the opportunity to bump SRCREV of xen_git.bb and xen-tools_git.bb
to the current status of master.
Signed-off-by: Michal Orzel <michal.orzel@arm.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | recipes-extended/xen/xen-hypervisor.inc | 8 | ||||
-rw-r--r-- | recipes-extended/xen/xen-tools_git.bb | 4 | ||||
-rw-r--r-- | recipes-extended/xen/xen.inc | 6 | ||||
-rw-r--r-- | recipes-extended/xen/xen_git.bb | 4 |
4 files changed, 12 insertions, 10 deletions
diff --git a/recipes-extended/xen/xen-hypervisor.inc b/recipes-extended/xen/xen-hypervisor.inc index 81e361f1..6f3d24d0 100644 --- a/recipes-extended/xen/xen-hypervisor.inc +++ b/recipes-extended/xen/xen-hypervisor.inc | |||
@@ -48,6 +48,14 @@ do_configure() { | |||
48 | fi | 48 | fi |
49 | } | 49 | } |
50 | 50 | ||
51 | # The hypervisor binary for arm must not be built with the hard floating point | ||
52 | # ABI. Override CC and CPP when invoking make so that they do not contain | ||
53 | # TUNE_CCARGS. | ||
54 | EXTRA_OEMAKE:arm += "CC='${CCACHE}${HOST_PREFIX}gcc ${TOOLCHAIN_OPTIONS} \ | ||
55 | ${CC_REPRODUCIBLE_OPTIONS}' \ | ||
56 | CPP='${CCACHE}${HOST_PREFIX}gcc -E ${TOOLCHAIN_OPTIONS} \ | ||
57 | ${CC_REPRODUCIBLE_OPTIONS}'" | ||
58 | |||
51 | do_compile() { | 59 | do_compile() { |
52 | oe_runmake xen PYTHON="${PYTHON}" \ | 60 | oe_runmake xen PYTHON="${PYTHON}" \ |
53 | EXTRA_CFLAGS_XEN_CORE="${EXTRA_CFLAGS_XEN_CORE}" | 61 | EXTRA_CFLAGS_XEN_CORE="${EXTRA_CFLAGS_XEN_CORE}" |
diff --git a/recipes-extended/xen/xen-tools_git.bb b/recipes-extended/xen/xen-tools_git.bb index 8ff9c4c1..e733f1d6 100644 --- a/recipes-extended/xen/xen-tools_git.bb +++ b/recipes-extended/xen/xen-tools_git.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # master status on 2020-10-21 | 1 | # master status on 2022-03-08 |
2 | SRCREV ?= "23ec1ebc8acbfd2bf06f6085a776f0db923f9fa9" | 2 | SRCREV ?= "9d4a44380d273de22d5753883cbf5581795ff24d" |
3 | 3 | ||
4 | XEN_REL ?= "4.16" | 4 | XEN_REL ?= "4.16" |
5 | XEN_BRANCH ?= "master" | 5 | XEN_BRANCH ?= "master" |
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc index 4df99bf6..8b86de5f 100644 --- a/recipes-extended/xen/xen.inc +++ b/recipes-extended/xen/xen.inc | |||
@@ -193,12 +193,6 @@ do_post_patch() { | |||
193 | fi | 193 | fi |
194 | } | 194 | } |
195 | 195 | ||
196 | do_post_patch:append:arm() { | ||
197 | # The hypervisor binary must not be built with the hard floating point ABI. | ||
198 | echo "CC := \$(filter-out ${TUNE_CCARGS},\$(CC))" >> ${S}/xen/arch/arm/Rules.mk | ||
199 | echo "CPP := \$(filter-out ${TUNE_CCARGS},\$(CPP))" >> ${S}/xen/arch/arm/Rules.mk | ||
200 | } | ||
201 | |||
202 | addtask post_patch after do_patch before do_configure | 196 | addtask post_patch after do_patch before do_configure |
203 | 197 | ||
204 | # Allow all hypervisor settings in a defconfig | 198 | # Allow all hypervisor settings in a defconfig |
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb index e0147334..2fbfb548 100644 --- a/recipes-extended/xen/xen_git.bb +++ b/recipes-extended/xen/xen_git.bb | |||
@@ -1,5 +1,5 @@ | |||
1 | # master status on 2020-10-21 | 1 | # master status on 2022-03-08 |
2 | SRCREV ?= "23ec1ebc8acbfd2bf06f6085a776f0db923f9fa9" | 2 | SRCREV ?= "9d4a44380d273de22d5753883cbf5581795ff24d" |
3 | 3 | ||
4 | XEN_REL ?= "4.16" | 4 | XEN_REL ?= "4.16" |
5 | XEN_BRANCH ?= "master" | 5 | XEN_BRANCH ?= "master" |