summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-extended/xen/xen-hypervisor.inc8
-rw-r--r--recipes-extended/xen/xen-tools_git.bb4
-rw-r--r--recipes-extended/xen/xen.inc6
-rw-r--r--recipes-extended/xen/xen_git.bb4
4 files changed, 12 insertions, 10 deletions
diff --git a/recipes-extended/xen/xen-hypervisor.inc b/recipes-extended/xen/xen-hypervisor.inc
index 81e361f1..6f3d24d0 100644
--- a/recipes-extended/xen/xen-hypervisor.inc
+++ b/recipes-extended/xen/xen-hypervisor.inc
@@ -48,6 +48,14 @@ do_configure() {
48 fi 48 fi
49} 49}
50 50
51# The hypervisor binary for arm must not be built with the hard floating point
52# ABI. Override CC and CPP when invoking make so that they do not contain
53# TUNE_CCARGS.
54EXTRA_OEMAKE:arm += "CC='${CCACHE}${HOST_PREFIX}gcc ${TOOLCHAIN_OPTIONS} \
55 ${CC_REPRODUCIBLE_OPTIONS}' \
56 CPP='${CCACHE}${HOST_PREFIX}gcc -E ${TOOLCHAIN_OPTIONS} \
57 ${CC_REPRODUCIBLE_OPTIONS}'"
58
51do_compile() { 59do_compile() {
52 oe_runmake xen PYTHON="${PYTHON}" \ 60 oe_runmake xen PYTHON="${PYTHON}" \
53 EXTRA_CFLAGS_XEN_CORE="${EXTRA_CFLAGS_XEN_CORE}" 61 EXTRA_CFLAGS_XEN_CORE="${EXTRA_CFLAGS_XEN_CORE}"
diff --git a/recipes-extended/xen/xen-tools_git.bb b/recipes-extended/xen/xen-tools_git.bb
index 8ff9c4c1..e733f1d6 100644
--- a/recipes-extended/xen/xen-tools_git.bb
+++ b/recipes-extended/xen/xen-tools_git.bb
@@ -1,5 +1,5 @@
1# master status on 2020-10-21 1# master status on 2022-03-08
2SRCREV ?= "23ec1ebc8acbfd2bf06f6085a776f0db923f9fa9" 2SRCREV ?= "9d4a44380d273de22d5753883cbf5581795ff24d"
3 3
4XEN_REL ?= "4.16" 4XEN_REL ?= "4.16"
5XEN_BRANCH ?= "master" 5XEN_BRANCH ?= "master"
diff --git a/recipes-extended/xen/xen.inc b/recipes-extended/xen/xen.inc
index 4df99bf6..8b86de5f 100644
--- a/recipes-extended/xen/xen.inc
+++ b/recipes-extended/xen/xen.inc
@@ -193,12 +193,6 @@ do_post_patch() {
193 fi 193 fi
194} 194}
195 195
196do_post_patch:append:arm() {
197 # The hypervisor binary must not be built with the hard floating point ABI.
198 echo "CC := \$(filter-out ${TUNE_CCARGS},\$(CC))" >> ${S}/xen/arch/arm/Rules.mk
199 echo "CPP := \$(filter-out ${TUNE_CCARGS},\$(CPP))" >> ${S}/xen/arch/arm/Rules.mk
200}
201
202addtask post_patch after do_patch before do_configure 196addtask post_patch after do_patch before do_configure
203 197
204# Allow all hypervisor settings in a defconfig 198# Allow all hypervisor settings in a defconfig
diff --git a/recipes-extended/xen/xen_git.bb b/recipes-extended/xen/xen_git.bb
index e0147334..2fbfb548 100644
--- a/recipes-extended/xen/xen_git.bb
+++ b/recipes-extended/xen/xen_git.bb
@@ -1,5 +1,5 @@
1# master status on 2020-10-21 1# master status on 2022-03-08
2SRCREV ?= "23ec1ebc8acbfd2bf06f6085a776f0db923f9fa9" 2SRCREV ?= "9d4a44380d273de22d5753883cbf5581795ff24d"
3 3
4XEN_REL ?= "4.16" 4XEN_REL ?= "4.16"
5XEN_BRANCH ?= "master" 5XEN_BRANCH ?= "master"