diff options
author | Jonatan Pålsson <jonatan.palsson@pelagicore.com> | 2017-03-27 08:43:30 +0200 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@windriver.com> | 2017-03-28 09:09:41 -0400 |
commit | ea05b2693aa6eae10a5f59aa7a47e52b4c4b4acd (patch) | |
tree | fda547f88032003e39bded373d95e86e529777d9 | |
parent | bccfd5ddb908b82511869701a41be056c0414a1b (diff) | |
download | meta-virtualization-ea05b2693aa6eae10a5f59aa7a47e52b4c4b4acd.tar.gz |
lxc: Add lua to PACKAGECONFIG
Lua support is automatically enabled when configuring LXC if lua is
available in the sysroot. The packaging step will fail since the lua
related files are not in FILES.
This patch explicitly enables/disables lua support using PACKAGECONFIG,
and also adds lua-related files to FILES.
Signed-off-by: Jonatan Pålsson <jonatan.palsson@pelagicore.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r-- | recipes-containers/lxc/lxc_2.0.0.bb | 4 |
1 files changed, 4 insertions, 0 deletions
diff --git a/recipes-containers/lxc/lxc_2.0.0.bb b/recipes-containers/lxc/lxc_2.0.0.bb index 250ac4d9..c98d1a7f 100644 --- a/recipes-containers/lxc/lxc_2.0.0.bb +++ b/recipes-containers/lxc/lxc_2.0.0.bb | |||
@@ -65,6 +65,7 @@ PACKAGECONFIG[templates] = ",,, ${PN}-templates" | |||
65 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" | 65 | PACKAGECONFIG[selinux] = "--enable-selinux,--disable-selinux,libselinux,libselinux" |
66 | PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" | 66 | PACKAGECONFIG[seccomp] ="--enable-seccomp,--disable-seccomp,libseccomp,libseccomp" |
67 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core" | 67 | PACKAGECONFIG[python] = "--enable-python,--disable-python,python3,python3-core" |
68 | PACKAGECONFIG[lua] = "--enable-lua,--disable-lua,lua,lua" | ||
68 | 69 | ||
69 | # required by python3 to run setup.py | 70 | # required by python3 to run setup.py |
70 | export BUILD_SYS | 71 | export BUILD_SYS |
@@ -86,6 +87,9 @@ FILES_${PN}-doc = "${mandir} ${infodir}" | |||
86 | # For LXC the docdir only contains example configuration files and should be included in the lxc package | 87 | # For LXC the docdir only contains example configuration files and should be included in the lxc package |
87 | FILES_${PN} += "${docdir}" | 88 | FILES_${PN} += "${docdir}" |
88 | FILES_${PN} += "${libdir}/python3*" | 89 | FILES_${PN} += "${libdir}/python3*" |
90 | FILES_${PN} += "${datadir}/lua/*" | ||
91 | FILES_${PN} += "${libdir}/lua/lxc/*" | ||
92 | FILES_${PN}-dbg += "${libdir}/lua/lxc/.debug" | ||
89 | FILES_${PN}-dbg += "${libexecdir}/lxc/.debug ${libexecdir}/lxc/hooks/.debug" | 93 | FILES_${PN}-dbg += "${libexecdir}/lxc/.debug ${libexecdir}/lxc/hooks/.debug" |
90 | PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking" | 94 | PACKAGES =+ "${PN}-templates ${PN}-setup ${PN}-networking" |
91 | FILES_${PN}-templates += "${datadir}/lxc/templates" | 95 | FILES_${PN}-templates += "${datadir}/lxc/templates" |