summaryrefslogtreecommitdiffstats
path: root/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@gmail.com>2020-06-30 23:42:03 -0400
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-07-01 12:43:16 -0400
commitcc5e41ffb029ed61711e14368e66083e22a6ba38 (patch)
treea7c09b6649de1a08516c971e3999e9a4263eb15b /recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch
parent929372946aeb85953d1ca6acc428d73fbac52a56 (diff)
downloadmeta-virtualization-cc5e41ffb029ed61711e14368e66083e22a6ba38.tar.gz
docker-distribution: fix for GO cross compilation
With oe-core commit c23f9e80492e4b [tcmode-default: use go-binary-native by default], we must explictly call the proper cross go binary, versus just the go-native variant. These builds were working by luck, since the go compiler was capable of building the target binaries previously (in its build-from-source creation). We fixup the calls and we no longer see fpu build issues: fatal error: gnu/stubs-soft.h: No such file or directory 7 | # include <gnu/stubs-soft.h> | ^~~~~~~~~~~~~~~~~~ Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch')
-rw-r--r--recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch
new file mode 100644
index 00000000..393b167f
--- /dev/null
+++ b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch
@@ -0,0 +1,29 @@
1From 9c27a12dc0bc62b95d7ecf003e7d241b36c3f2e6 Mon Sep 17 00:00:00 2001
2From: Bruce Ashfield <bruce.ashfield@gmail.com>
3Date: Tue, 30 Jun 2020 23:35:05 -0400
4Subject: [PATCH] build: use to use cross go compiler
5
6We shouldn't be invoking 'go' as the compiler, but instead use
7${GO} which tracks our cross build go compiler for the architecture.
8
9Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
10---
11 Makefile | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-)
13
14diff --git a/Makefile b/Makefile
15index 4635c6ec..a95e860e 100644
16--- a/Makefile
17+++ b/Makefile
18@@ -88,7 +88,7 @@ FORCE:
19 # Build a binary from a cmd.
20 bin/%: cmd/% FORCE
21 @echo "$(WHALE) $@${BINARY_SUFFIX}"
22- @go build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$<
23+ @${GO} build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$<
24
25 binaries: $(BINARIES) ## build binaries
26 @echo "$(WHALE) $@"
27--
282.19.1
29