diff options
Diffstat (limited to 'recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch')
-rw-r--r-- | recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch new file mode 100644 index 00000000..393b167f --- /dev/null +++ b/recipes-containers/docker-distribution/files/0001-build-use-to-use-cross-go-compiler.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 9c27a12dc0bc62b95d7ecf003e7d241b36c3f2e6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Tue, 30 Jun 2020 23:35:05 -0400 | ||
4 | Subject: [PATCH] build: use to use cross go compiler | ||
5 | |||
6 | We shouldn't be invoking 'go' as the compiler, but instead use | ||
7 | ${GO} which tracks our cross build go compiler for the architecture. | ||
8 | |||
9 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
10 | --- | ||
11 | Makefile | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/Makefile b/Makefile | ||
15 | index 4635c6ec..a95e860e 100644 | ||
16 | --- a/Makefile | ||
17 | +++ b/Makefile | ||
18 | @@ -88,7 +88,7 @@ FORCE: | ||
19 | # Build a binary from a cmd. | ||
20 | bin/%: cmd/% FORCE | ||
21 | @echo "$(WHALE) $@${BINARY_SUFFIX}" | ||
22 | - @go build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< | ||
23 | + @${GO} build ${GO_GCFLAGS} ${GO_BUILD_FLAGS} -o $@${BINARY_SUFFIX} ${GO_LDFLAGS} ${GO_TAGS} ./$< | ||
24 | |||
25 | binaries: $(BINARIES) ## build binaries | ||
26 | @echo "$(WHALE) $@" | ||
27 | -- | ||
28 | 2.19.1 | ||
29 | |||