summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--conf/distro/include/meta-virt-xen.inc2
-rw-r--r--dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend6
2 files changed, 2 insertions, 6 deletions
diff --git a/conf/distro/include/meta-virt-xen.inc b/conf/distro/include/meta-virt-xen.inc
index 1ad670ed..fe3fd221 100644
--- a/conf/distro/include/meta-virt-xen.inc
+++ b/conf/distro/include/meta-virt-xen.inc
@@ -15,5 +15,7 @@ IMAGE_FSTYPES_append_raspberrypi4-64 = " rpi-sdimg"
15# Add Xen to the bootable SD card image 15# Add Xen to the bootable SD card image
16RPI_SDIMG_EXTRA_DEPENDS_append_raspberrypi4-64 = " xen:do_deploy" 16RPI_SDIMG_EXTRA_DEPENDS_append_raspberrypi4-64 = " xen:do_deploy"
17DEPLOYPAYLOAD_raspberrypi4-64 = "xen-${MACHINE}:xen" 17DEPLOYPAYLOAD_raspberrypi4-64 = "xen-${MACHINE}:xen"
18# We need the GIC enabled for Xen to work
19RPI_EXTRA_CONFIG_append_raspberrypi4-64 = "\nenable_gic=1"
18# Align kernel version with current meta-virtualization kernel version 20# Align kernel version with current meta-virtualization kernel version
19PREFERRED_VERSION_linux-raspberrypi ?= "5.4.%" 21PREFERRED_VERSION_linux-raspberrypi ?= "5.4.%"
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
deleted file mode 100644
index 2b9c4fbc..00000000
--- a/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
1do_deploy_append() {
2 # We need the GIC enabled for Xen to work.
3 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'yes', 'no', d)}" = "yes" ]; then
4 echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
5 fi
6}