diff options
author | Christopher Clark <christopher.w.clark@gmail.com> | 2020-08-07 00:05:01 -0700 |
---|---|---|
committer | Bruce Ashfield <bruce.ashfield@gmail.com> | 2020-08-11 15:58:37 -0400 |
commit | 738bd333a9d3d39b12643efd1f1afe60d0e3080d (patch) | |
tree | 5c340ed5d222401939fa02878d6740704e539c15 | |
parent | 681591b5b8879a7607cff8ca5dfb0adf7f69051b (diff) | |
download | meta-virtualization-738bd333a9d3d39b12643efd1f1afe60d0e3080d.tar.gz |
xen, rpi4: use RPI_EXTRA_CONFIG and drop the rpi-config_git.bbappend
The GIC that is needed by Xen can be enabled via the rpi-config recipe
variable. Fixes the build after the upstream recipe changed recently.
Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com>
Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
-rw-r--r-- | conf/distro/include/meta-virt-xen.inc | 2 | ||||
-rw-r--r-- | dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend | 6 |
2 files changed, 2 insertions, 6 deletions
diff --git a/conf/distro/include/meta-virt-xen.inc b/conf/distro/include/meta-virt-xen.inc index 1ad670ed..fe3fd221 100644 --- a/conf/distro/include/meta-virt-xen.inc +++ b/conf/distro/include/meta-virt-xen.inc | |||
@@ -15,5 +15,7 @@ IMAGE_FSTYPES_append_raspberrypi4-64 = " rpi-sdimg" | |||
15 | # Add Xen to the bootable SD card image | 15 | # Add Xen to the bootable SD card image |
16 | RPI_SDIMG_EXTRA_DEPENDS_append_raspberrypi4-64 = " xen:do_deploy" | 16 | RPI_SDIMG_EXTRA_DEPENDS_append_raspberrypi4-64 = " xen:do_deploy" |
17 | DEPLOYPAYLOAD_raspberrypi4-64 = "xen-${MACHINE}:xen" | 17 | DEPLOYPAYLOAD_raspberrypi4-64 = "xen-${MACHINE}:xen" |
18 | # We need the GIC enabled for Xen to work | ||
19 | RPI_EXTRA_CONFIG_append_raspberrypi4-64 = "\nenable_gic=1" | ||
18 | # Align kernel version with current meta-virtualization kernel version | 20 | # Align kernel version with current meta-virtualization kernel version |
19 | PREFERRED_VERSION_linux-raspberrypi ?= "5.4.%" | 21 | PREFERRED_VERSION_linux-raspberrypi ?= "5.4.%" |
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend deleted file mode 100644 index 2b9c4fbc..00000000 --- a/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend +++ /dev/null | |||
@@ -1,6 +0,0 @@ | |||
1 | do_deploy_append() { | ||
2 | # We need the GIC enabled for Xen to work. | ||
3 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'yes', 'no', d)}" = "yes" ]; then | ||
4 | echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt | ||
5 | fi | ||
6 | } | ||