diff options
Diffstat (limited to 'recipes-extended')
6 files changed, 73 insertions, 56 deletions
diff --git a/recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch b/recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch deleted file mode 100644 index cd504ce5..00000000 --- a/recipes-extended/fuse-overlayfs/fuse-overlayfs/0001-utils-Add-missing-include-on-limits.h.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | From b48e958aaecfdfc3bb48db082a548a09d6487181 Mon Sep 17 00:00:00 2001 | ||
2 | From: Andrei Gherzan <andrei.gherzan@huawei.com> | ||
3 | Date: Wed, 13 Jul 2022 12:05:07 +0200 | ||
4 | Subject: [PATCH] utils: Add missing include on limits.h | ||
5 | |||
6 | This happens to not be an issue with glibc because it gets indirectly | ||
7 | included via dirent.h: | ||
8 | |||
9 | .. /usr/include/dirent.h | ||
10 | [...] | ||
11 | ..... /usr/include/linux/limits.h | ||
12 | |||
13 | When using the musl libc implementation, that is not the case anymore | ||
14 | and the build fails. | ||
15 | |||
16 | Signed-off-by: Andrei Gherzan <andrei.gherzan@huawei.com> | ||
17 | Upstream-Status: Submitted [https://github.com/containers/fuse-overlayfs/pull/362] | ||
18 | --- | ||
19 | utils.h | 1 + | ||
20 | 1 file changed, 1 insertion(+) | ||
21 | |||
22 | diff --git a/utils.h b/utils.h | ||
23 | index 13a177e..6fbc328 100644 | ||
24 | --- a/utils.h | ||
25 | +++ b/utils.h | ||
26 | @@ -32,6 +32,7 @@ | ||
27 | # include <sys/types.h> | ||
28 | # include <fcntl.h> | ||
29 | # include "fuse-overlayfs.h" | ||
30 | +# include <limits.h> | ||
31 | |||
32 | # define XATTR_OVERRIDE_STAT "user.fuseoverlayfs.override_stat" | ||
33 | # define XATTR_PRIVILEGED_OVERRIDE_STAT "security.fuseoverlayfs.override_stat" | ||
34 | -- | ||
35 | 2.25.1 | ||
36 | |||
diff --git a/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb b/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb new file mode 100644 index 00000000..0f6d0fb6 --- /dev/null +++ b/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.14.bb | |||
@@ -0,0 +1,15 @@ | |||
1 | SUMMARY = "FUSE implementation of overlayfs." | ||
2 | DESCRIPTION = "An implementation of overlay+shiftfs in FUSE for rootless \ | ||
3 | containers." | ||
4 | |||
5 | LICENSE = "GPL-2.0-or-later" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
7 | |||
8 | SRCREV = "33cb788edc05f5e3cbb8a7a241f5a04bee264730" | ||
9 | SRC_URI = "git://github.com/containers/fuse-overlayfs.git;nobranch=1;protocol=https" | ||
10 | |||
11 | DEPENDS = "fuse3" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | inherit autotools pkgconfig | ||
diff --git a/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb b/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb deleted file mode 100644 index 31199928..00000000 --- a/recipes-extended/fuse-overlayfs/fuse-overlayfs_1.9.bb +++ /dev/null | |||
@@ -1,18 +0,0 @@ | |||
1 | SUMMARY = "FUSE implementation of overlayfs." | ||
2 | DESCRIPTION = "An implementation of overlay+shiftfs in FUSE for rootless \ | ||
3 | containers." | ||
4 | |||
5 | LICENSE = "GPL-3.0-or-later" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" | ||
7 | |||
8 | SRCREV = "51592ea406f48faeccab288f65dcba6c4a67cd90" | ||
9 | SRC_URI = " \ | ||
10 | git://github.com/containers/fuse-overlayfs.git;nobranch=1;protocol=https \ | ||
11 | file://0001-utils-Add-missing-include-on-limits.h.patch \ | ||
12 | " | ||
13 | |||
14 | DEPENDS = "fuse3" | ||
15 | |||
16 | S = "${WORKDIR}/git" | ||
17 | |||
18 | inherit autotools pkgconfig | ||
diff --git a/recipes-extended/libvirt/libvirt_git.bb b/recipes-extended/libvirt/libvirt_git.bb index 4c6b3bdd..7ed708f5 100644 --- a/recipes-extended/libvirt/libvirt_git.bb +++ b/recipes-extended/libvirt/libvirt_git.bb | |||
@@ -47,9 +47,10 @@ S = "${WORKDIR}/git" | |||
47 | 47 | ||
48 | inherit meson gettext update-rc.d pkgconfig systemd useradd perlnative | 48 | inherit meson gettext update-rc.d pkgconfig systemd useradd perlnative |
49 | USERADD_PACKAGES = "${PN}" | 49 | USERADD_PACKAGES = "${PN}" |
50 | GROUPADD_PARAM:${PN} = "-r qemu; -r kvm" | 50 | GROUPADD_PARAM:${PN} = "-r qemu; -r kvm; -r libvirt; -r virtlogin" |
51 | USERADD_PARAM:${PN} = "-r -g qemu -G kvm qemu" | 51 | USERADD_PARAM:${PN} = "-r -g qemu -G kvm qemu" |
52 | 52 | ||
53 | CFLAGS += "${@oe.utils.vartrue('DEBUG_BUILD', '-Wno-error=inline', '', d)}" | ||
53 | 54 | ||
54 | EXTRA_OEMESON += "--cross-file ${WORKDIR}/meson-${PN}.cross" | 55 | EXTRA_OEMESON += "--cross-file ${WORKDIR}/meson-${PN}.cross" |
55 | do_write_config:append() { | 56 | do_write_config:append() { |
diff --git a/recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch b/recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch new file mode 100644 index 00000000..4b2c0bdf --- /dev/null +++ b/recipes-extended/xen/files/0001-xen-fix-header-guard-inconsistencies-gcc15.patch | |||
@@ -0,0 +1,54 @@ | |||
1 | From 70f96461462a5a0437398022aa71a2033c8c5c3a Mon Sep 17 00:00:00 2001 | ||
2 | From: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
3 | Date: Thu, 15 May 2025 14:26:47 -0400 | ||
4 | Subject: [PATCH] xen: fix header guard inconsistencies (gcc15) | ||
5 | |||
6 | Fixing the following header inconsistencies | ||
7 | |||
8 | | In file included from arch/arm/platforms/midway.c:22: | ||
9 | | ./arch/arm/include/asm/platforms/midway.h:1: error: header guard '__ASM_ARM_PLATFORMS_MIDWAY_H' followed by '#define' of a different macro [-Werror=header-guard] | ||
10 | | 1 | #ifndef __ASM_ARM_PLATFORMS_MIDWAY_H | ||
11 | | ./arch/arm/include/asm/platforms/midway.h:2: note: '__ASM_ASM_PLATFORMS_MIDWAY_H' is defined here; did you mean '__ASM_ARM_PLATFORMS_MIDWAY_H'? | ||
12 | | 2 | #define __ASM_ASM_PLATFORMS_MIDWAY_H | ||
13 | | In file included from arch/arm/platforms/omap5.c:21: | ||
14 | | ./arch/arm/include/asm/platforms/omap5.h:1: error: header guard '__ASM_ARM_PLATFORMS_OMAP5_H' followed by '#define' of a different macro [-Werror=header-guard] | ||
15 | | 1 | #ifndef __ASM_ARM_PLATFORMS_OMAP5_H | ||
16 | | ./arch/arm/include/asm/platforms/omap5.h:2: note: '__ASM_ASM_PLATFORMS_OMAP5_H' is defined here; did you mean '__ASM_ARM_PLATFORMS_OMAP5_H'? | ||
17 | |||
18 | It is unclear whether this is on purpose or not, but for our limited | ||
19 | set of permuations, we change them to match and no issues have been | ||
20 | found. | ||
21 | |||
22 | Upstream-Status: Pending [the xen folks understand the code and the right fix .. I don't] | ||
23 | |||
24 | Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com> | ||
25 | --- | ||
26 | xen/arch/arm/include/asm/platforms/midway.h | 2 +- | ||
27 | xen/arch/arm/include/asm/platforms/omap5.h | 2 +- | ||
28 | 2 files changed, 2 insertions(+), 2 deletions(-) | ||
29 | |||
30 | diff --git a/xen/arch/arm/include/asm/platforms/midway.h b/xen/arch/arm/include/asm/platforms/midway.h | ||
31 | index 099e4350f9..69143931c2 100644 | ||
32 | --- a/xen/arch/arm/include/asm/platforms/midway.h | ||
33 | +++ b/xen/arch/arm/include/asm/platforms/midway.h | ||
34 | @@ -1,5 +1,5 @@ | ||
35 | #ifndef __ASM_ARM_PLATFORMS_MIDWAY_H | ||
36 | -#define __ASM_ASM_PLATFORMS_MIDWAY_H | ||
37 | +#define __ASM_ARM_PLATFORMS_MIDWAY_H | ||
38 | |||
39 | /* addresses of SREG registers for resetting the SoC */ | ||
40 | #define MW_SREG_PWR_REQ 0xfff3cf00 | ||
41 | diff --git a/xen/arch/arm/include/asm/platforms/omap5.h b/xen/arch/arm/include/asm/platforms/omap5.h | ||
42 | index c559c84b61..8867b4589a 100644 | ||
43 | --- a/xen/arch/arm/include/asm/platforms/omap5.h | ||
44 | +++ b/xen/arch/arm/include/asm/platforms/omap5.h | ||
45 | @@ -1,5 +1,5 @@ | ||
46 | #ifndef __ASM_ARM_PLATFORMS_OMAP5_H | ||
47 | -#define __ASM_ASM_PLATFORMS_OMAP5_H | ||
48 | +#define __ASM_ARM_PLATFORMS_OMAP5_H | ||
49 | |||
50 | #define REALTIME_COUNTER_BASE 0x48243200 | ||
51 | #define INCREMENTER_NUMERATOR_OFFSET 0x10 | ||
52 | -- | ||
53 | 2.39.2 | ||
54 | |||
diff --git a/recipes-extended/xen/xen_4.20.bb b/recipes-extended/xen/xen_4.20.bb index d8324033..85c56296 100644 --- a/recipes-extended/xen/xen_4.20.bb +++ b/recipes-extended/xen/xen_4.20.bb | |||
@@ -1,4 +1,4 @@ | |||
1 | SRCREV ?= "3ad5d648cda5add395f49fc3704b2552aae734f7" | 1 | SRCREV ?= "47d911f69eb976785fd17cae4e39de4d55b94b9e" |
2 | 2 | ||
3 | XEN_REL ?= "4.20.0" | 3 | XEN_REL ?= "4.20.0" |
4 | XEN_BRANCH ?= "stable-4.20" | 4 | XEN_BRANCH ?= "stable-4.20" |
@@ -6,6 +6,7 @@ XEN_BRANCH ?= "stable-4.20" | |||
6 | SRC_URI = " \ | 6 | SRC_URI = " \ |
7 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ | 7 | git://xenbits.xen.org/xen.git;branch=${XEN_BRANCH} \ |
8 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ | 8 | file://0001-menuconfig-mconf-cfg-Allow-specification-of-ncurses-location.patch \ |
9 | file://0001-xen-fix-header-guard-inconsistencies-gcc15.patch \ | ||
9 | " | 10 | " |
10 | 11 | ||
11 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" | 12 | LIC_FILES_CHKSUM ?= "file://COPYING;md5=d1a1e216f80b6d8da95fec897d0dbec9" |