diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-09-04 10:37:19 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-09-07 10:02:11 -0700 |
commit | 383fb93e8bc8fea089d2f3c47e264e63bb103f9a (patch) | |
tree | 1738c78907b932330b9a63ebe558f24c1ad89dff | |
parent | 1d42de61facdb19eacc36af18d4c2014bbd0d4e4 (diff) | |
download | meta-openembedded-383fb93e8bc8fea089d2f3c47e264e63bb103f9a.tar.gz |
python3-kivy: Remove hardcoded include paths
Use RECIPE_SYSROOT instead of synthesizing the sysroot
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: William Huang <whuang8933@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | 20 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb | 2 |
2 files changed, 18 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch index e50c7e7e24..bb236b4195 100644 --- a/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch +++ b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | |||
@@ -1,8 +1,6 @@ | |||
1 | diff --git a/setup.py b/setup.py | ||
2 | index 9a507c6c4..3f5b70866 100644 | ||
3 | --- a/setup.py | 1 | --- a/setup.py |
4 | +++ b/setup.py | 2 | +++ b/setup.py |
5 | @@ -680,7 +680,18 @@ def determine_gl_flags(): | 3 | @@ -695,7 +695,18 @@ def determine_gl_flags(): |
6 | c_options['use_x11'] = True | 4 | c_options['use_x11'] = True |
7 | c_options['use_egl'] = True | 5 | c_options['use_egl'] = True |
8 | else: | 6 | else: |
@@ -22,3 +20,19 @@ index 9a507c6c4..3f5b70866 100644 | |||
22 | return flags, base_flags | 20 | return flags, base_flags |
23 | 21 | ||
24 | 22 | ||
23 | @@ -723,14 +734,13 @@ def determine_sdl2(): | ||
24 | sdl_inc = join(include, 'SDL2') | ||
25 | if isdir(sdl_inc): | ||
26 | sdl2_paths.append(sdl_inc) | ||
27 | - sdl2_paths.extend(['/usr/local/include/SDL2', '/usr/include/SDL2']) | ||
28 | |||
29 | flags['include_dirs'] = sdl2_paths | ||
30 | flags['extra_link_args'] = [] | ||
31 | flags['extra_compile_args'] = [] | ||
32 | flags['library_dirs'] = ( | ||
33 | sdl2_paths if sdl2_paths else | ||
34 | - ['/usr/local/lib/']) | ||
35 | + ['']) | ||
36 | |||
37 | if sdl2_flags: | ||
38 | flags = merge(flags, sdl2_flags) | ||
diff --git a/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb b/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb index 3f6bafda81..63c2ae7334 100644 --- a/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb +++ b/meta-python/recipes-devtools/python/python3-kivy_2.0.0.bb | |||
@@ -39,7 +39,7 @@ export USE_X11 | |||
39 | KIVY_GRAPHICS = "gles" | 39 | KIVY_GRAPHICS = "gles" |
40 | export KIVY_GRAPHICS | 40 | export KIVY_GRAPHICS |
41 | 41 | ||
42 | KIVY_CROSS_SYSROOT="${WORKDIR}/recipe-sysroot" | 42 | KIVY_CROSS_SYSROOT="${RECIPE_SYSROOT}" |
43 | export KIVY_CROSS_SYSROOT | 43 | export KIVY_CROSS_SYSROOT |
44 | 44 | ||
45 | DEPENDS += " \ | 45 | DEPENDS += " \ |