summaryrefslogtreecommitdiffstats
path: root/dynamic-layers/raspberrypi
diff options
context:
space:
mode:
authorChristopher Clark <christopher.w.clark@gmail.com>2020-08-07 00:05:01 -0700
committerBruce Ashfield <bruce.ashfield@gmail.com>2020-08-11 15:58:37 -0400
commit738bd333a9d3d39b12643efd1f1afe60d0e3080d (patch)
tree5c340ed5d222401939fa02878d6740704e539c15 /dynamic-layers/raspberrypi
parent681591b5b8879a7607cff8ca5dfb0adf7f69051b (diff)
downloadmeta-virtualization-738bd333a9d3d39b12643efd1f1afe60d0e3080d.tar.gz
xen, rpi4: use RPI_EXTRA_CONFIG and drop the rpi-config_git.bbappend
The GIC that is needed by Xen can be enabled via the rpi-config recipe variable. Fixes the build after the upstream recipe changed recently. Signed-off-by: Christopher Clark <christopher.w.clark@gmail.com> Signed-off-by: Bruce Ashfield <bruce.ashfield@gmail.com>
Diffstat (limited to 'dynamic-layers/raspberrypi')
-rw-r--r--dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend6
1 files changed, 0 insertions, 6 deletions
diff --git a/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend b/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
deleted file mode 100644
index 2b9c4fbc..00000000
--- a/dynamic-layers/raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bbappend
+++ /dev/null
@@ -1,6 +0,0 @@
1do_deploy_append() {
2 # We need the GIC enabled for Xen to work.
3 if [ "${@bb.utils.contains('DISTRO_FEATURES', 'xen', 'yes', 'no', d)}" = "yes" ]; then
4 echo "enable_gic=1" >> ${DEPLOYDIR}/bcm2835-bootfiles/config.txt
5 fi
6}